Organizing

 

JetPhoto Studio enables user to organize photos by notes, keyword tags, camera tags, time and geographical location.

 

Photo Information

User can retrieve and edit some photo properties in JetPhoto Studio. Select Information side tabbed panel to show an information list that contains some items, such as Image Size, Camera Model, Shutter Speed, Capture Date and something else. A part of items can be edited in this list, double click the value field to edit its content.

Properties Editable Descriptions
File Name YES File name of the original image file
Size (Bytes) NO File size in bytes
Width NO Image width in pixels
Height NO Image height in pixels
Created Date NO Date and time to create this image file
Modified Date NO Date and time to modified this image file lastly
Archived Date NO Date and time to import this image file into album
- - -
Camera Maker YES Camera maker name, eg. Nikon
Camera Model YES Camera model, eg. D200
Aperture YES F number
Focal Length YES Focal length (mm)
Focus Distance YES Focus distance (meter)
Shutter Speed YES Shutter speed (second)
ISO Speed YES Sensitivity, eg. ISO 100, ISO 400, ISO 800
Flash YES Flash status, On or Off
- - -
Capture Date YES Date and time to take this shot (yyyy-mm-dd hh:mm:ss)
Longitude YES Longitude (-180° ~ 180° )
Latitude YES Latitude (-90° ~ 90°)
Elevation YES Altitude in meters (zero altitude is the sea level)
Heading YES Camera Heading (0 ~ 360°)

 

File Name
If you want to change file name for current photo, just need to double click the item File Name in photo information list, and then you can type a new filename in an editable text field.

EXIF Tags
At the moment when you take a shot, digital camera usually writes the additional camera parameters into EXIF data saved with the image data together in a JPEG picture file. The Photo Information properties mostly are retrieved from the EXIF data tags enclosed in JPEG file, such as Camera Model, Shutter Speed, Flash status, etc.

The photo info properties are editable, but the modified properties don't be written into EXIF of the original JPEG files automatically. Instead, JetPhoto Studio saves them in a separate XML file to keep all metadata for photos in the album. JetPhoto Studio always avoids to change the contents of original photo files.

Location Tags
One of the key features of JetPhoto Studio is to organize photos by location. So any photos in JetPhoto album may have a set of properties pointing to a place where the photo was taken. These geographical properties are Longitude, Latitude and Elevation. For the details, please also refer to section GPS and Geotagging (Mac) or GPS and Geotagging (Windows) in this document.

After editing Longitude, Latitude or Elevation property, you can also choose menu item 'EXIF Tools'-> 'Merge GPS Metadata into JPEG' to write location information into original JPEG files.

 

Notes and keywords

User can set notes and keywords for each photo item in JetPhoto album. Select Notes side tabbed panel, there are a text box for editing note and a keyword list.

Notes (Descriptions)
Select one photo item in thumbnail view, or switch current photo in detail view. Type note to describe the selected photo in Notes panel.

Set photo notes in batches
Sometimes you may set notes for several photos in batches. Multi-select several photo items in thumbnail view. Type note to describe these selected photos, and click the button with gearwheel icon in Notes panel, choose item 'Set Notes for Multi-selected Photos' in the pop-up menu.

Copy filenames to photo notes
Without JetPhoto Studio, the photo files are usually named as the photo titles. If you imported your titled files into JetPhoto albums, you may need a convenient tool to transfer the photo titles from the file names to the photo notes shortly. Now you can just do that with an easy click, please choose menu item “Edit”->“Copy Filenames to Photo Notes…”

See the sample, the original file name is ‘Birthday Cake.JPG’.

After copying, now the photo note become ‘Birthday Cake’.

Keywords (Tags)
In Mac OS X version, double click keyword list in Notes panel to add or edit the assignable keywords for current album. You can also copy keywords between two lists in different albums by drag-and-drop the selected keyword item. Or, you can first prepare a keywords list in a text file, and click button 'Import' to load the keywords from the file into your album anytime later.

Select one or several photo items in Thumbnail view, or switch current photo in Detail view. Click the checkbox of the given item in keyword list to assign this keyword for the selected photos.

In Windows version, there are three buttons below the keywords list, click them to add, remove or modify keywords.

(Add, Remove and Modify buttons)

Select one or several photo items in Thumbnail view, or switch current photo in Detail view. And select the keywords in list, click the checkbox button to assign the selected keywords for the selected photos. To cancel the assigned keywords, click the unchecked box button.

(Assign and Unassign buttons)

You can also try to exchange the keywords between different lists by copy-and-paste. Select some items in keywords list, click right mouse button, and choose context menu item ‘Copy’ to copy the selected keywords onto clipboard. Select the keywords list in another album window, click right mouse button, and choose context menu item ‘Paste’ to transfer the copied keywords to new list. Or, you can first prepare a keywords list in a text editor, then copy the keywords from the text file and paste them to your album anytime later.

Favorite Keywords Presets (Mac only)
JetPhoto Studio Mac version provideds the functionality to manage your keywords with Favorite Keywords Presets, a mechanism to organize the global keywords with flexibility.

The Favorite Keywords Presets combo box appears below the keywords list in Notes panel.
- To save the current keywords list to a Favorite Keywords Preset, please enter a name in the combo box first, and click button ‘Save’.
- To load a Favorite Keywords Preset to the current keywords list, please select a preset listed in combo box, and click button ‘Load’. To update keywords list, JetPhoto provides two modes that can be chosen, ‘Replace’ or ‘Merge’.

At present, the Favorite Keywords Presets feature is only available in Mac version. However if you'd like to save your favorite keywords in files with Windows version, just need to select keyword items in list, copy them to clipboard, and paste to a text file editor. In this way, it's very easy to edit and manage your keywords presets with any text editor software. Also, the inverse operation is copying a favorite keywords list from a text file and pasting to an album window.

Stars
For your favorite or selected photos in album, you can also mark stars for them. Select one or several photo items in Thumbnail view, or switch current photo in Detail view. Click Star button in Notes panel to add or remove stars for the photos.

(photo marked with star)

Perhaps you need to select the photos marked with Star before running some processing sometimes. For example, to make a Flash gallery with all star-marked photos in this album. And then, you just need to choose menu item 'Edit'->'Select star-marked photos'.

Search photos
Type text in search bar in Notes panel and press Return key to search photos with the specific note or keyword.

Click the button with gearwheel icon in Notes panel, choose item 'Find All Noted Photos' in the pop-up menu to find all photos with non-blank note.

Click the button with gearwheel icon in Notes panel, choose item 'Find Photos with Selected Keyword' in the pop-up menu to find the photos with the selected keyword.

All found items are spotlighted in thumbnail view. Choose menu item 'Edit'->'Select Spotlighted Photos' or press Ctrl-A to select all matched photos.

IPTC
After editing notes or keywords, you can also choose menu item 'EXIF Tools'-> 'Merge Notes/Keywords into JPEG' to write notes and keywords into IPTC data of original JPEG files. (This function may not work properly with Eastern Asian character sets.)

 

Filenames

In Information side tabbed panel, you can see the filenames of the current selected photo stored in the album. If you'd like to change the filename of the photo file, just need double-click the File field in the file information list, and then you can edit the filename. You should keep same file extensions while renaming files.

RAW files can be archived in JetPhoto albums, but the filename shown in File field is the JPEG copy of the RAW file. The information of the RAW file is listed in section 'Camera Raw' of the list. RAW filename is not editable in JetPhoto Studio.

Rename files in batches with multiple modes
Choose menu item “Edit”->“Batch Rename Files…”, you can use the tool to change filenames in batches for the selected photos. The tool enables flexible renaming photo files as a series of uniform names with a same prefix (or/and a same suffix), and add an index number or a time string into each filename automatically. The program can also read the EXIF photo capture time tags and write them into the filenames. In this way, you can always easily sort your photo files by events or categories in any environment even without JetPhoto Studio.


Example 1: rename files by appending index numbers


Example 2: rename files by appending photo capture time


Example 3: rename files with a prefix-time-suffix combination, example, you can name photo files as Event + Time + Location

 

Calendar

For most people the easiest and most efficient method to organize photos is based on the date and time when the photos were taken. Using JetPhoto, you can log your travel by taking photos, or use digital camera to compose your multimedia diary.

JetPhoto Studio offers a calendar interface to help user review photos. There is nothing for you to do!! JetPhoto obtains the photo capture time automatically and properly, as long as photos are imported from a digital camera.

The specified date or time when user took photos will be highlighted in Month View or Week View. In this way, user can quickly pick out the needed photos by timeline.

Month view
Select 'Month View' mode in Calendar extra panel, there will be twelve months displayed in one calendar view. The date when user took photos will be highlighted with white flags. The date of the current selected photo will be highlighted with a red flag. Click a date cell to find the photos taken during this day.


(Week view and Month view)

Week view
Select 'Week View' mode in Calendar extra panel, the every hour in 7 days will be displayed as one cell in the calendar view. The hour when user took photos will be highlighted with white marks. The hour of the current selected photo will be highlighted with a red marks. Click an hour cell to find the photos taken during this hour.

Time different retrieve
When you travel and take photos in different time zones, you should adjust the internal clock of your digital camera to meet the local time. If you forgot to do then, you can also retrieve the photo capture time in JetPhoto Studio.

Select photos in Thumbnail view, click the button with gearwheel icon in Calendar panel, choose item 'Time Different Retrieve for Selected Photos' in the pop-up menu to show a dialog box, in which select the hour number of time difference to change photo capture time. If you don't know how to calculate time difference, please click Help button to have an interface to choose the home & destination time zones of your travel.

Capture Time Corrector
Digital photo is usually saved with a time stamp recording the capture time, so you should ensure the internal clock setting of your digital camera is correct. If your camera clock setting is incorrect before, you can also update capture time for archived photos in batches.

Select photos in Thumbnail view, click the button with gearwheel icon in Calendar panel, choose item 'Correct Capture Time for Selected Photos' in the pop-up menu to show a dialog box, in which select the time offset (by days, hours, minutes or seconds) to change the capture time.

Arrange photos by time
Click the button with gearwheel icon in Calendar panel, choose item 'Arrange All Photos by Time' in the pop-up menu to rearrange all photo items in the order they were taken. And you can find more options to sort your photos in menu 'Edit'->'Arrange Photos'.

 

Map

JetPhoto Studio enables user to locate and track photos on digital geographical map using GPS technology. In JetPhoto Studio, user can browse photos with a map view, on which points the places where the photos were taken. User can also review photos with an enclosed detailed map to show the photo location in Geotag extra panel.


(Map view and Geotag extra panel)

For more details about organizing photos with Map, please see section GPS and Geotagging in this document. Due to the different original design, the GPS and geotagging functionality between Mac version and Windows version is also a bit different. So two sections to introduce GPS and Geotagging features for Mac users and Windows users are provided separately.

 

Album Manager (Windows)

JetPhoto Studio Windows version provides an efficient tool to help user to organize all albums located on the disks.

After JetPhoto Studio is launched, you will see the Album Manager window. It helps user to manage photo albums saved on disks conveniently. There are three icons on the up-left corner, which are represented as “My Photo Albums”, “My Computer” and “My Desktop”. Click one of these icons, you can find out albums you wanted in any location. For more convenience, we suggest that you’d better organize your albums in “My Photo Albums”

Once seeing a number after a folder name listed in the tree view, such as “Selected (3)”, it means that the folder named Selected has got three albums. Only need to single-click the folder, the three albums will appear in the album browser view vividly.

While browsing albums, for convenience, there are two options to sort albums listed, sorting albums by album name or created date.

Change photo albums library path
The default My Photo Albums directory is located at folder “My Photo Albums” of “My Documents”. If you want to modify the library path, you can choose menu item “Edit”-> “Options”, and set your new directory below “My Photo Albums Library Path” in “Options” window.

New category
If you want to add a new category in the tree view, you can click the button “New Category”, and name the new category. The category is just a folder in the file system.

New album
Firstly, select a category listed in the tree view, then click the button “New Album” below the album browser view, or select menu item “File”->“New Album”, name the album. An empty album will be created and automatically opened.

Open album
Click an album item in the album browser view, it will expand to show some relative information of this album. Click the enclosed OPEN button to open this album.

Move album
If you want to move an album from one category to another, only need to select an album in album browser view and drag it into a category item in tree view.

 

Global Search

JetPhoto Studio version also provides a module to search photos in all albums saved in any place on your disk.

- Choose menu item ‘File’->‘Global Search’ to launch Global Search window.
- Set text filter for searching in tab panel ‘Search’.
- Set time and location filters for searching if necessary.
- Select the places on disk where the albums saved.
- Click button ‘Search’, the result will be listed in tab panel ‘Result’.
- Double-click an item in result list to open it in album window. The matched photos will be spotlighted in thumbnail view.